Deathball 2.1 on a multi-mod server

Problems setting up a server and other server related things

Moderators: Jay2k1, The_One, DavidM

Deathball 2.1 on a multi-mod server

Postby Imaginos » 22-08-2004 23:21

Hi all! I've been a little busy as of late and haven't had enough time to give 2.1 a firm shakedown, but I have hit an issue that is close to the heart in the desired way that I run my server.

As many Deathball regulars know, I'm one of the biggest pimps on the web for UT2Vote, which gives server admins the ability to host multiple mods using a feature we call dynamic serverpackages. Utilizing this, your players will never have to download any packages that aren't in use at the time of connection! You can switch from Deathball to JailBreak, to Unwheel, to ChaosUT and back to Deathball again with ease. Only the mod running right then and there has active serverpackage lines. Revolutionary? Hell yes! Try it out today and say goodbye to mapvote forever.. But back to the issue..

Deathball 2.1 known issue for Multi-Mod servers:

This post assumes Deathball was installed and is started in the traditional way (i.e NOT using the -mod switch as documented here: http://forums.gameservers.net/showthread.php?s=&threadid=12667 ). An updated post for 2.1 installation will be written soon.

Clients will experience an Incompatable File error for this file: 2K4Menus.utx and will lose connection. There is a second conflicting file called UT2004Thumbnails.utx, but this error will never be seen since the client disconnects upon the first error. This issue is due to the new custom menus enployed in the latest version of Deathball. The changes are client-side and there is a workaround for those admins that wish to host multiple mods.

To prevent the version conflicts, the two affected files must have changes made to their packageflags to identify the files to the server as both "ServerSideOnly" and also "ClientOptional".

I have done this already and you need only replace the two conflicting texture files on your server with the files contained in this zip: http://bud.recongamer.com/deathball/multimod.zip
Files should be copied/uploaded to ../ut2004/textures. Your clients will again be able to connect normally.
User avatar
Imaginos
 
Posts: 887
Joined: 17-03-2003 18:06

Postby trog » 26-08-2004 06:00

I was having this problem, but on a box without any other mods on it (though they're installed, but not running, if that makes any difference).

The server is starting without the -mod switch. Clients can't join from the command line or third party clients - they get dumped straight at the menu with a lot of stuff like :

ScriptLog: GameInfo::InitGame : bEnableStatLogging False
Warning: Failed to load 'NULL': Can't resolve package name
Warning: Failed to load 'Class None.': Can't resolve package name
Warning: Failed to load 'NULL': Can't resolve package name

... appearing in the deathball log file.

However, they can join fine from the in-game menu/browser. I tried your modified textures, but it had the same effect. Is there any way to diagnose this further short of wading through billions of lines of annoying .ini files?
trog
Junior Member
 
Posts: 1
Joined: 26-08-2004 05:29

Postby Imaginos » 28-08-2004 07:31

I normally just use
Suppress=Warning

These are brought on by the maps usually.. doesn't affect gameplay.
User avatar
Imaginos
 
Posts: 887
Joined: 17-03-2003 18:06

Postby torin » 14-06-2008 09:30

Oops! Looks like multimod.zip is missing. The link is dead. But I did find a simple explanation of how to generate the files it contained.

From the BeyondUnreal forums:

Forcing mods and TCs to work with stock UT2004 files

Cool thing is, the method can be applied to other files/mods with the same problem. \o/
torin
Junior Member
 
Posts: 2
Joined: 14-06-2008 09:02

Postby SAHJester » 22-06-2008 23:08

Well i got a copy of the textures...

And the server still crashes on start...

Server paths:
Paths=../deathball/System/*.u
Paths=../deathball/Maps/*.ut2
Paths=../deathball/Textures/*.utx
Paths=../deathball/Sounds/*.uax
Paths=../deathball/Music/*.umx
Paths=../deathball/StaticMeshes/*.usx
Paths=../deathball/Animations/*.ukx

Server Packages:
ServerPackages=Deathball
ServerPackages=Deathball_rc
ServerPackages=DeathballAI
ServerPackages=DeathballSP

Well yeah does any one have any ideas to fix it?
Last edited by SAHJester on 23-06-2008 01:43, edited 1 time in total.
SAHJester
Junior Member
 
Posts: 2
Joined: 22-06-2008 23:05

Postby The_One » 23-06-2008 16:36

Can you link to your .ini file?
User avatar
The_One
Senior Member
 
Posts: 1965
Joined: 09-03-2003 00:38
Location: UK

Postby SAHJester » 23-06-2008 19:31

Yeah its attached

Also there is alot of other game types and mutators....
All the files not deathball are needed..

Have fun it looks like a jungle :lol:
SAHJester
Junior Member
 
Posts: 2
Joined: 22-06-2008 23:05

Postby The_One » 24-06-2008 14:04

Code: Select all
Paths=../deathball/System/*.u

Is your deathball folder actually lower-case? Is the server running on Linux or Mac perchance? You might want to check whether the folder is actually called 'Deathball' (note the capitalisation of the first letter) and edit the paths accordingly.
User avatar
The_One
Senior Member
 
Posts: 1965
Joined: 09-03-2003 00:38
Location: UK


Return to Death Ball Servers

Who is online

Users browsing this forum: No registered users and 1 guest

cron